Mislukking van outoudate op WordPress? FTP misluk?

WordPressOnlangs het ons 'n kliënt gehad wat hul eie bedieners gekonfigureer het vir gebruik saam met WordPress. Wanneer die onlangse 3.04 sekuriteit die opdatering deurgedring het, was daar 'n mate van dringendheid om hierdie weergawe op al ons kliënte te laat installeer. Hierdie spesifieke kliënt het egter altyd vereis dat ons WordPress handmatig moet opgradeer ... 'n proses wat nie maklik is nie!

Ons sou nie die tipiese “kan nie lêers skryf nie”Fout op hierdie blog. In plaas daarvan het ons 'n skerm met FTP-aanmelding gekry. Die probleem was dat ons die FTP-referensies sou invul, en dit sou wel nog steeds misluk... hierdie keer gebaseer op goeie geloofsbriewe!

Ek het kontak gemaak met ons vriende by Lifeline Data Centers, Indiana's grootste datasentrum, aangesien hulle 'n paar Apache-geeks het en hul eie bedieners gekonfigureer het. Hulle het my 'n eenvoudige oplossing gegee - om die FTP-referensies direk by die wp-config.php lêer om die FTP-referensies te hardkode:

definieer ('FTP_HOST', 'localhost'); definieer ('FTP_USER', 'gebruikersnaam'); definieer ('FTP_PASS', 'wagwoord');

Om een ​​of ander rede het dieselfde identifikasies wat nie in die vorm gewerk het nie, perfek gewerk toe dit in die konfigurasielêer geplaas is! Dit laat WordPress ook optree soos dit sou gebeur sonder dat FTP nodig was ... kliek net op update en gaan!

4 Comments

  1. 1

    Ek het foute met die outomatiese opdatering van WordPress ondervind nadat ek my bediener herbou en 'n nuwe WordPress-installasie laat draai het. My probleem het ontstaan ​​uit Firefox, nie WordPress nie - ander kan dieselfde probleem ervaar as hul FTP-gebruikersnaam en WordPress-gebruikersnaam dieselfde is as myne (alhoewel met verskillende hoofletters en wagwoorde).

    Die probleem is dat Firefox, as u 'wagwoorde onthou' geaktiveer het, die gebruiker outomaties sal regstel / in die vorm sal deurgee na wat hy dink dit moet gebaseer wees op wat in die wagwoordbestuurder gestoor is. In my geval is my WordPress-referensies gestoor, maar my FTP-referenties nie, aangesien dit gebruik kan word om SSH op die webwerf te gebruik. Mense in hierdie situasie kan "wagwoorde onthou" tydelik in hul Voorkeure / Opsies uitskakel wanneer hulle probeer om WordPress outo-opdatering te gebruik, of 'n stuk kode op WordPress toepas om hierdie gedrag reg te stel.

  2. 2

    Doug,

    Ek het dieselfde probleem gehad met die bou van Apache. Dit blyk dat dit die gevolg was van onbehoorlike toestemmings en eienaarskap van sekere lêers en gidse.

    http://robspencer.net/auto-update-wordpress-without-ftp/

    Die skakel hierbo het insig gegee in die oplossing van die probleem sonder om ftp-referensies te gebruik. Ek beveel natuurlik nie aan dat u u hele gebruikersgids tot 775 wys nie (en ek het nie), maar dit lei my in die regte rigting.

    Adam

  3. 3

    Vir ander wat op soek is na moontlike oplossings: 'n Ander blogger het sy probleme met outomatiese opdaterings opgelos deur sy gasheer blykbaar te dwing om php5 te gebruik deur die volgende by sy .httaccess-lêer te voeg:

    AddType x-mapp-php5 .php

  4. 4

    Dankie dat u die kennis gedeel het. Ek het probleme ondervind met outoudatums, maar die enigste oplossing wat ek gevind het, is om die invoegtoepassings te deaktiveer, dan WordPress outomaties te werk en uiteindelik al die invoegtoepassings te reageer.

    Hierdie wenk is vir 'n ander probleem, maar dit is goed om te weet hoe om dit op te los.

    Groete uit Mexiko!

Wat dink jy?

Hierdie webwerf gebruik Akismet om spam te verminder. Leer hoe jou opmerking verwerk is.